Working u-boot-tools

This commit is contained in:
nemunaire 2015-02-17 03:16:25 +01:00
parent 11cfc5dcd0
commit f236677b84
3 changed files with 36 additions and 27 deletions

View File

@ -1,2 +1,2 @@
AUX 000_change_abi.patch 728 SHA256 7741121a2b8c12602f76591e99c4f5fcee6c22dc96727f8aa9fb3487c8fe957e SHA512 28502103636b822a86ac72c17288fbea560e887b3b0aa39883f07e7381bdd790d3435c22a7c1451ef92bff7708e3e8bf56d79c0ec26a611a6a4a9ff4ab4b4ba7 WHIRLPOOL 61fdb1c8be1d974aeda5cb475cb4b617f587d83b893b15aeef7d0858903d6434f0420ccf144c93d914d9c87b21e8aa36d2a50ecf048ef4da287bfaf67b3a262a
EBUILD u-boot-tools-odroidc1-2011.03.ebuild 1021 SHA256 2984b4b767878a482c1f22a894b890b1cb04e493585fddae2a7e5fcfaf33accb SHA512 47ba92d77b9c828b017a11739d9bdc4ba71939839389f11f01c096aa596a2cbc0d43eb7bd85e2703dea0fb41dc9b7ffa4408c1157d9306fefacaf2b9e631ce42 WHIRLPOOL 7aea72d9a6c13ce49d4a4808632255015fd22507672c8e05d75adc2db927a3c3e4d51cc517e0f84ca4cd0d6d9bc4ec7c7bb16c96bdcdda0e679c287e2a75b089
AUX 000_change_abi.patch 1124 SHA256 9136fa21ba31ac9ec4fa5820d3f8fc049a4722368ad1e10b0dc27c2d7103f683 SHA512 36ef79e5cbb69f7b4582939615b94ec522fa764ac06956193758d7fac1e21cafeafca6a43423b31dcac2c09a6e679b61c0df956f34a40125e6138335046efa6f WHIRLPOOL abfaabd56ea816b8658b14da387b18941662ae25490fcffc67ecf450d55d3ac219c9b74ad3115ca9bb8e29a9fe7abbc98c9a7b97e131ee94919fef3eef6d06c3
EBUILD u-boot-tools-odroidc1-2011.03.ebuild 960 SHA256 aa5712f49d97caa499cd8c7c37ff42a172c4002c1519038a0764080bc7658482 SHA512 098c1b1f0e59c6c5a12f4f9c60595afc83b4dd5e44fe6c4dd7ce28afc838f90de67739b0060a187d36e21e89acdd32115c98a2d74b780527f4ca3a8d27468c9d WHIRLPOOL 29d2604198e5b6a8f452b303076c1322b2801c220b8f28ec3fa1c2b4a08c66afb4c38e23188edd5c497e02973d009d7cb464a43db1e6fa25f48eef0a75eef626

View File

@ -11,7 +11,6 @@ index 0f9bffe..910723b 100755
#arm-linux-
ifeq ($(BOARD),omap2420h4)
diff --git a/arch/arm/cpu/aml_meson/config.mk b/arch/arm/cpu/aml_meson/config.mk
index 0f9bffe..910723b 100755
--- a/arch/arm/cpu/aml_meson/config.mk
@ -21,4 +20,17 @@ index 0f9bffe..910723b 100755
+CROSS_COMPILE=armv7a-hardfloat-linux-gnueabi-
ARM_CPU=cortex-a9
PLATFORM_CPPFLAGS += $(call cc-option,-mcpu=cortex-a9 -ffixed-r8 -mno-long-calls -Wall -fPIC )
#USE_PRIVATE_LIBGCC=yes
PF_CPPFLAGS_NO_UNALIGNED := $(call cc-option, -mno-unaligned-access,)
diff --git a/tools/env/Makefile b/tools/env/Makefile
index 0f9bffe..910723b 100644
--- a/tools/env/Makefile
+++ b/tools/env/Makefile
@@ -25,7 +25,7 @@ include $(TOPDIR)/config.mk
ifdef CONFIG_AML_MESON
HOSTSRCS := fw_env_aml.c
-HOSTCC = arm-none-linux-gnueabi-gcc
+HOSTCC = armv7a-hardfloat-linux-gnueabi-gcc
else
HOSTSRCS := fw_env.c
endif

View File

@ -1,30 +1,31 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
EAPI=5
inherit eutils toolchain-funcs git-2 versionator
ETYPE=sources
MY_P="u-boot-${PV/_/-}"
EGIT_REPO_URI=https://github.com/hardkernel/u-boot
EGIT_PROJECT="u-boot.git"
EGIT_BRANCH="odroidc-v2011.03"
inherit eutils git-r3 versionator
EGIT_REPO_URI=git://github.com/hardkernel/u-boot.git
EGIT_BRANCH="odroidc-v$(get_version_component_range 1-2)"
EGIT_CHECKOUT_DIR="$S"
DESCRIPTION="Odroid C1 U-Boot"
HOMEPAGE="https://github.com/hardkernel/u-boot"
SLOT=0
LICENSE="GPL-2"
KEYWORDS="amd64 arm x86"
IUSE=""
S=${WORKDIR}/${MY_P}
KEYWORDS="~arm"
src_unpack() {
git-2_src_unpack
git-r3_src_unpack
}
src_prepare() {
epatch "${FILESDIR}"/000_change_abi.patch
}
src_compile() {
export ARCH=arm
emake \
@ -33,17 +34,13 @@ src_compile() {
HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
odroidc_config
emake
emake tools-all
}
src_install() {
cd tools
dobin bmp_logo gen_eth_addr img2srec mkimage
dobin easylogo/easylogo
dobin env/fw_printenv
dosym fw_printenv /usr/bin/fw_setenv
insinto /etc
doins env/fw_env.config
cd ..
cd build/tools
dobin bmp_logo easylogo/easylogo env/fw_printenv gen_eth_addr img2srec inca-swap-bytes mkimage ncb ubsha1 uclpack
cd ../..
insinto /opt/hardkernel
dodir sd_fuse
}