Add u-boot and linux kernel
This commit is contained in:
parent
02f91e1bc7
commit
76bfeaab31
@ -2,3 +2,6 @@ Odroid-C1 Gentoo Overlay
|
|||||||
========================
|
========================
|
||||||
|
|
||||||
This overlay includes ebuilds for the following packages:
|
This overlay includes ebuilds for the following packages:
|
||||||
|
|
||||||
|
* `dev-embedded/u-boot-tools-odroidc1`: Odroid C1 U-Boot (https://github.com/hardkernel/u-boot)
|
||||||
|
* `sys-kernel/odroidc1-sources`: Linux source for Odroid devices (https://github.com/hardkernel/linux)
|
||||||
|
2
dev-embedded/u-boot-tools-odroidc1/Manifest
Normal file
2
dev-embedded/u-boot-tools-odroidc1/Manifest
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
AUX 000_change_abi.patch 728 SHA256 7741121a2b8c12602f76591e99c4f5fcee6c22dc96727f8aa9fb3487c8fe957e SHA512 28502103636b822a86ac72c17288fbea560e887b3b0aa39883f07e7381bdd790d3435c22a7c1451ef92bff7708e3e8bf56d79c0ec26a611a6a4a9ff4ab4b4ba7 WHIRLPOOL 61fdb1c8be1d974aeda5cb475cb4b617f587d83b893b15aeef7d0858903d6434f0420ccf144c93d914d9c87b21e8aa36d2a50ecf048ef4da287bfaf67b3a262a
|
||||||
|
EBUILD u-boot-tools-odroidc1-2011.03.ebuild 1021 SHA256 2984b4b767878a482c1f22a894b890b1cb04e493585fddae2a7e5fcfaf33accb SHA512 47ba92d77b9c828b017a11739d9bdc4ba71939839389f11f01c096aa596a2cbc0d43eb7bd85e2703dea0fb41dc9b7ffa4408c1157d9306fefacaf2b9e631ce42 WHIRLPOOL 7aea72d9a6c13ce49d4a4808632255015fd22507672c8e05d75adc2db927a3c3e4d51cc517e0f84ca4cd0d6d9bc4ec7c7bb16c96bdcdda0e679c287e2a75b089
|
@ -0,0 +1,24 @@
|
|||||||
|
diff --git a/arch/arm/config.mk b/arch/arm/config.mk
|
||||||
|
index 0f9bffe..910723b 100755
|
||||||
|
--- a/arch/arm/config.mk
|
||||||
|
+++ b/arch/arm/config.mk
|
||||||
|
@@ -21,7 +21,7 @@
|
||||||
|
# MA 02111-1307 USA
|
||||||
|
#
|
||||||
|
|
||||||
|
-CROSS_COMPILE ?= arm-none-eabi-
|
||||||
|
+CROSS_COMPILE ?= armv7a-hardfloat-linux-gnueabi-
|
||||||
|
#arm-linux-
|
||||||
|
|
||||||
|
ifeq ($(BOARD),omap2420h4)
|
||||||
|
|
||||||
|
diff --git a/arch/arm/cpu/aml_meson/config.mk b/arch/arm/cpu/aml_meson/config.mk
|
||||||
|
index 0f9bffe..910723b 100755
|
||||||
|
--- a/arch/arm/cpu/aml_meson/config.mk
|
||||||
|
+++ b/arch/arm/cpu/aml_meson/config.mk
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-CROSS_COMPILE=arm-none-eabi-
|
||||||
|
+CROSS_COMPILE=armv7a-hardfloat-linux-gnueabi-
|
||||||
|
ARM_CPU=cortex-a9
|
||||||
|
PLATFORM_CPPFLAGS += $(call cc-option,-mcpu=cortex-a9 -ffixed-r8 -mno-long-calls -Wall -fPIC )
|
||||||
|
#USE_PRIVATE_LIBGCC=yes
|
@ -0,0 +1,49 @@
|
|||||||
|
# Copyright 1999-2015 Gentoo Foundation
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI="5"
|
||||||
|
|
||||||
|
inherit eutils toolchain-funcs git-2 versionator
|
||||||
|
|
||||||
|
MY_P="u-boot-${PV/_/-}"
|
||||||
|
EGIT_REPO_URI=https://github.com/hardkernel/u-boot
|
||||||
|
EGIT_PROJECT="u-boot.git"
|
||||||
|
EGIT_BRANCH="odroidc-v2011.03"
|
||||||
|
|
||||||
|
DESCRIPTION="Odroid C1 U-Boot"
|
||||||
|
HOMEPAGE="https://github.com/hardkernel/u-boot"
|
||||||
|
SLOT=0
|
||||||
|
LICENSE="GPL-2"
|
||||||
|
KEYWORDS="amd64 arm x86"
|
||||||
|
IUSE=""
|
||||||
|
|
||||||
|
S=${WORKDIR}/${MY_P}
|
||||||
|
src_unpack() {
|
||||||
|
git-2_src_unpack
|
||||||
|
}
|
||||||
|
|
||||||
|
src_prepare() {
|
||||||
|
epatch "${FILESDIR}"/000_change_abi.patch
|
||||||
|
}
|
||||||
|
src_compile() {
|
||||||
|
export ARCH=arm
|
||||||
|
emake \
|
||||||
|
HOSTSTRIP=: \
|
||||||
|
HOSTCC="$(tc-getCC)" \
|
||||||
|
HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
|
||||||
|
odroidc_config
|
||||||
|
emake
|
||||||
|
}
|
||||||
|
|
||||||
|
src_install() {
|
||||||
|
cd tools
|
||||||
|
dobin bmp_logo gen_eth_addr img2srec mkimage
|
||||||
|
dobin easylogo/easylogo
|
||||||
|
dobin env/fw_printenv
|
||||||
|
dosym fw_printenv /usr/bin/fw_setenv
|
||||||
|
insinto /etc
|
||||||
|
doins env/fw_env.config
|
||||||
|
cd ..
|
||||||
|
insinto /opt/hardkernel
|
||||||
|
dodir sd_fuse
|
||||||
|
}
|
1
sys-kernel/odroidc1-sources/Manifest
Normal file
1
sys-kernel/odroidc1-sources/Manifest
Normal file
@ -0,0 +1 @@
|
|||||||
|
EBUILD odroidc1-sources-3.10.9999.ebuild 596 SHA256 e619f51179606dc7b01adf650b8d62574d13030c9c0f7be0b6a326e5a6cce521 SHA512 9867c28de016f7a8f0c50223475bd2f56c2e1b4e5505b66d241e476e0f82df6e0a06a5d84e270120690dcac61948be0c95cbf35b1836ea43eb46742539ba6bc9 WHIRLPOOL 1be73a2ea7e4bac0d591521c807a19ab518c0d0949a740c3f35ee47506fd8d8c2947f8566ea5f07f216a9df99c0c05c7223fc83c62787d44dcd3df3c43957def
|
@ -0,0 +1,31 @@
|
|||||||
|
# Copyright 1999-2015 Gentoo Foundation
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=5
|
||||||
|
|
||||||
|
ETYPE=sources
|
||||||
|
K_DEFCONFIG="odroidc_defconfig"
|
||||||
|
K_SECURITY_UNSUPPORTED=1
|
||||||
|
EXTRAVERSION="-${PN}/-*"
|
||||||
|
|
||||||
|
inherit kernel-2
|
||||||
|
|
||||||
|
detect_version
|
||||||
|
detect_arch
|
||||||
|
|
||||||
|
inherit git-r3 versionator
|
||||||
|
|
||||||
|
EGIT_REPO_URI="git://github.com/hardkernel/linux.git"
|
||||||
|
EGIT_BRANCH="odroidc-$(get_version_component_range 1-2).y"
|
||||||
|
EGIT_CHECKOUT_DIR="$S"
|
||||||
|
|
||||||
|
DESCRIPTION="Linux source for Odroid devices"
|
||||||
|
HOMEPAGE="https://github.com/hardkernel/linux"
|
||||||
|
|
||||||
|
KEYWORDS="~arm"
|
||||||
|
|
||||||
|
src_unpack()
|
||||||
|
{
|
||||||
|
git-r3_src_unpack
|
||||||
|
unpack_set_extraversion
|
||||||
|
}
|
Loading…
Reference in New Issue
Block a user