New ebuild for Xorg DDX drivers
This commit is contained in:
parent
5cea1f90bb
commit
23ec0923fd
@ -5,4 +5,5 @@ This overlay includes ebuilds for the following packages:
|
||||
|
||||
* `dev-embedded/u-boot-tools-odroidc1`: Odroid C1 U-Boot (https://github.com/hardkernel/u-boot)
|
||||
* `sys-kernel/odroidc1-sources`: Linux source for Odroid devices (https://github.com/hardkernel/linux)
|
||||
* `x11-drivers/xf86-video-odroidc1`: Xorg DDX driver for Odroid-C1 (https://github.com/mdrjr/c1_mali_ddx)
|
||||
* `x11-libs/odroidc1-mali`: Closed source drivers for Mali (https://github.com/mdrjr/c1_mali_libs)
|
||||
|
2
x11-drivers/xf86-video-odroidc1/Manifest
Normal file
2
x11-drivers/xf86-video-odroidc1/Manifest
Normal file
@ -0,0 +1,2 @@
|
||||
AUX 0001-Fix-DESTDIR-when-performing-install.patch 668 SHA256 456ab739656ba737104450059e336d265cb088f5585c22880104d802ad5b3bf7 SHA512 b8cbe7c6a822c7e7b51a49d135f486606b33c7c96812897b55d784ccb39026a5ac8d808078d773177b53976128696069eea6532b3ffdc22d215c3b10bf32b64e WHIRLPOOL a119ed12c18b9d0cf2145edff92509aad4e9c78dec007cd3c784a31483775022dc919f2ac7c6e48515624390b50bac096d6bf24b988979684236cb38e7fcfc38
|
||||
EBUILD xf86-video-odroidc1-9999.ebuild 597 SHA256 417d9bb7a758cbfa82582ab480c51934f43ce32fb19c9515f8134c5817cc2251 SHA512 c4739526b2e9e3bd54c1ee8ceb9649173837f1c32bd42077827a27756ec7a2a235d66e66fe70ea9da6264fe4cdf7639f63dd0d04dd94caf62678430c0bda5ac0 WHIRLPOOL 170cf2178c9fca7f9db2631114988b5ebfc060026572db3c1b4c5c427be703e209ce646d0b2f606b30e0f78535f5609333f850478bf97c5b73120aee97ad99d7
|
@ -0,0 +1,26 @@
|
||||
From 57350db41ded13afde63bd168ea26a63afec0f70 Mon Sep 17 00:00:00 2001
|
||||
From: root <root@satis.nemunai.re>
|
||||
Date: Thu, 18 Jun 2015 02:33:50 +0200
|
||||
Subject: [PATCH] Fix DESTDIR when performing install
|
||||
|
||||
---
|
||||
src/Makefile.in | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/Makefile.in b/src/Makefile.in
|
||||
index 4b750f1..ebaa925 100644
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -529,7 +529,8 @@ install-dvi: install-dvi-am
|
||||
install-dvi-am:
|
||||
|
||||
install-exec-am:
|
||||
- install -m 0644 xorg.conf /etc/X11/xorg.conf
|
||||
+ mkdir -p "$(DESTDIR)/etc/X11/"
|
||||
+ install -m 0644 xorg.conf "$(DESTDIR)/etc/X11/xorg.conf"
|
||||
|
||||
|
||||
install-html: install-html-am
|
||||
--
|
||||
2.3.6
|
||||
|
@ -0,0 +1,28 @@
|
||||
EAPI=5
|
||||
|
||||
inherit autotools-utils xorg-2 git-r3
|
||||
|
||||
EGIT_REPO_URI="https://github.com/mdrjr/c1_mali_ddx.git"
|
||||
SRC_URI=""
|
||||
|
||||
DESCRIPTION="X.org Mali video driver for ODROID-C1"
|
||||
HOMEPAGE="http://www.hardkernel.com/"
|
||||
|
||||
KEYWORDS=""
|
||||
SLOT=0
|
||||
IUSE="gles1 gles2"
|
||||
|
||||
RDEPEND="x11-base/xorg-server"
|
||||
DEPEND="${RDEPEND}
|
||||
gles1? ( x11-libs/odroidc1-mali )
|
||||
gles2? ( x11-libs/odroidc1-mali )
|
||||
x11-proto/fontsproto
|
||||
x11-proto/xproto
|
||||
x11-libs/libdrm"
|
||||
|
||||
PATCHES=( "${FILESDIR}/0001-Fix-DESTDIR-when-performing-install.patch" )
|
||||
|
||||
src_compile() {
|
||||
autotools-utils_src_compile
|
||||
cp "./src/xorg.conf" "${BUILD_DIR}/src/xorg.conf"
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user