Add last e17 release from gentoo portage (was removed in october)
This commit is contained in:
parent
fa090c9817
commit
bd8a752aa5
4
x11-wm/enlightenment/Manifest
Normal file
4
x11-wm/enlightenment/Manifest
Normal file
@ -0,0 +1,4 @@
|
||||
AUX gentoo-sysactions.conf 3056 SHA256 5939973a9fbaaba81751e936fb541d6aebd7ec1c599174ea568f5a579356939f SHA512 688f02cbff0d50a847eb08ca7832699b836adca9b22e15a780943a8e5a8213aac04b335cfdf3cb96adbff238f681ae8954a720153e8e35b2afaba3225d53206a WHIRLPOOL 0c05e0d295ede8b2f436a87c4b98876fed64d5cc780f13bb6bde1a74a3c87847f2f90ab482a61c2b39f20894572329f5497e5da22537261eef2f0a9fb33ce56d
|
||||
AUX quickstart.diff 474 SHA256 9201674d2f8707f216e18c471f0a4a5a7366b3dd32cb8ec131ca1795a10bb3e6 SHA512 b8df654dd1246ea6391017fe9856e38d209b250625f8343aa4943a4eeed980447eb52c6a15fe170bcab90b76e5670ee9c7f98358bb87990877e312cc4cea8f6c WHIRLPOOL 7ea473b01d46ab1ae10ed50d9991de652e3c2945390a71dfa3cba4bf7c6d8ae526dbd18a275db7bd714be7e48414b90ea470c46d2460c68512ede070025b9c49
|
||||
DIST enlightenment-0.17.6.tar.bz2 29500129 SHA256 25ec72b40e7827468a2498fedfb03f86cb6f20101b63175d80c96db3157b0c0e SHA512 5f8fec0b2c9cb2bcc3e2738b68e4266179153288a161e4e2d0f7ff50b702d6d78d836b433105c548997b516324ca7ba44a74a7361052235b50e18c22a26c9dc9 WHIRLPOOL e89b52efa2007815ef4de9272102f5f170a3838666483a4653bdaa2f37291e14e92d6814dcbd7dfdfdcf14735dc37571b6fa1bf6f7b5a8c08070723d75e7d03a
|
||||
EBUILD enlightenment-0.17.6.ebuild 2094 SHA256 f4fc617f21f40c9abc3e520a69a29597dc027a52ce604891218992f96ccc8a71 SHA512 51270d87def22a4297b66061e47ed124eff2d801a877fc3fe84a46f23167a86645787bc52b2bc256b04da24efcda228b84b09d716229fc5d52c903d22687568b WHIRLPOOL 3ad0ec0c5bbbe8ee349a24993256c530030b2f2adb47149bf77e73e8e786366a4f6e3bd9e40128f79e70e3a653033f4199218f6b4c682e5fc04c04a3fe8192f9
|
79
x11-wm/enlightenment/enlightenment-0.17.6.ebuild
Normal file
79
x11-wm/enlightenment/enlightenment-0.17.6.ebuild
Normal file
@ -0,0 +1,79 @@
|
||||
# Copyright 1999-2014 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=5
|
||||
|
||||
inherit autotools enlightenment
|
||||
|
||||
DESCRIPTION="Enlightenment DR17 window manager"
|
||||
SRC_URI="https://download.enlightenment.org/releases/${P}.tar.bz2"
|
||||
|
||||
LICENSE="BSD-2"
|
||||
KEYWORDS="amd64 x86"
|
||||
SLOT="0.17/${PV%%_*}"
|
||||
|
||||
# The @ is just an anchor to expand from
|
||||
__EVRY_MODS=""
|
||||
__CONF_MODS="
|
||||
+@applications +@dialogs +@display +@edgebindings
|
||||
+@interaction +@intl +@keybindings +@menus
|
||||
+@paths +@performance +@randr +@shelves +@theme
|
||||
+@window-manipulation +@window-remembers"
|
||||
__NORM_MODS="
|
||||
@access +@backlight +@battery +@clock +@comp +@connman +@cpufreq +@dropshadow
|
||||
+@everything +@fileman +@fileman-opinfo +@gadman +@ibar +@ibox +@illume2
|
||||
+@mixer +@msgbus +@notification +@pager +@quickaccess +@shot +@start
|
||||
+@syscon +@systray +@tasks +@temperature +@tiling +@winlist +@wizard +@xkbswitch"
|
||||
IUSE_E_MODULES="
|
||||
${__CONF_MODS//@/enlightenment_modules_conf-}
|
||||
${__NORM_MODS//@/enlightenment_modules_}"
|
||||
|
||||
IUSE="pam spell static-libs +udev ukit ${IUSE_E_MODULES}"
|
||||
|
||||
RDEPEND="
|
||||
pam? ( sys-libs/pam )
|
||||
|| ( >=dev-libs/efl-1.8.4[X,eet,jpeg(+),png] >=dev-libs/efl-1.8.4[xcb,eet,jpeg(+),png] )
|
||||
>=dev-libs/e_dbus-1.7.10
|
||||
ukit? ( >=dev-libs/e_dbus-1.7.10[udev] )
|
||||
x11-libs/xcb-util-keysyms"
|
||||
DEPEND="${RDEPEND}"
|
||||
|
||||
S=${WORKDIR}/${P%%_*}
|
||||
|
||||
src_prepare() {
|
||||
sed -i "s:1.7.10:1.7.9:g" configure.ac
|
||||
eautoreconf
|
||||
epatch "${FILESDIR}"/quickstart.diff
|
||||
enlightenment_src_prepare
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
E_ECONF+=(
|
||||
--disable-install-sysactions
|
||||
--disable-elementary
|
||||
$(use_enable doc)
|
||||
--disable-device-hal
|
||||
--enable-emotion
|
||||
--disable-mount-hal
|
||||
$(use_enable nls)
|
||||
$(use_enable pam)
|
||||
--enable-device-udev
|
||||
$(use_enable udev mount-eeze)
|
||||
$(use_enable ukit mount-udisks)
|
||||
--disable-physics
|
||||
)
|
||||
local u c
|
||||
for u in ${IUSE_E_MODULES} ; do
|
||||
u=${u#+}
|
||||
c=${u#enlightenment_modules_}
|
||||
E_ECONF+=( $(use_enable ${u} ${c}) )
|
||||
done
|
||||
enlightenment_src_configure
|
||||
}
|
||||
|
||||
src_install() {
|
||||
enlightenment_src_install
|
||||
insinto /etc/enlightenment
|
||||
newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
|
||||
}
|
76
x11-wm/enlightenment/files/gentoo-sysactions.conf
Normal file
76
x11-wm/enlightenment/files/gentoo-sysactions.conf
Normal file
@ -0,0 +1,76 @@
|
||||
# ENLIGHTENMENT SYSTEM ACTIONS CONFIGURATION
|
||||
#
|
||||
# This is a system configuration for allowing or denying certain users or
|
||||
# groups to be able to do certain actions that involve system restricted
|
||||
# actions such as halt, reboot, suspend, hibernate etc.
|
||||
#
|
||||
# This file is read in order from top to bottom - the first rule to MATCH
|
||||
# will be used for a user or a group, and nothing after that is read.
|
||||
#
|
||||
# You must put all the ACTION definitons BEFORE user and group rule matches.
|
||||
# Any action definitons after a rule match has been found will be ignored.
|
||||
# This allows actions to be re-defined for different user groups, so matches
|
||||
# so the command for an action can change for matches to the rules later on.
|
||||
#
|
||||
# Any user or group NOT matched by an allow or a deny will be ALLOWED to
|
||||
# perform the action by default (system administrators should be aware of
|
||||
# this and implement whatever policies they see fit). Generally speaking
|
||||
# a user of a workstation, desktop or laptop is intended to have such abilities
|
||||
# to perform these actions, thus the default of allow. For multi-user systems
|
||||
# the system administrator is considerd capable enough to restrict what they
|
||||
# see they need to.
|
||||
#
|
||||
# A WARNING to admins: do NOT allow access for users to this system remotely
|
||||
# UNLESS you fully trust them or you have locked down permissions to halt/reboot
|
||||
# suspend etc. here first. You have been warned.
|
||||
#
|
||||
# FORMAT:
|
||||
#
|
||||
# action: halt /sbin/shutdown -h now
|
||||
# action: reboot /sbin/shutdown -r now
|
||||
# action: suspend /etc/acpi/sleep.sh force
|
||||
# action: hibernate /etc/acpi/hibernate.sh force
|
||||
#
|
||||
# user: username allow: halt reboot suspend hibernate
|
||||
# group: groupname deny: *
|
||||
# group: * deny: *
|
||||
# user: * allow: suspend
|
||||
# user: billy allow: halt reboot
|
||||
# group: staff deny: halt suspend hibernate
|
||||
#
|
||||
# etc.
|
||||
#
|
||||
# user and group name can use glob matches (* == all for example) like the
|
||||
# shell. as can action names allowed or denied.
|
||||
|
||||
action: halt /sbin/shutdown -h now
|
||||
action: reboot /sbin/shutdown -r now
|
||||
action: suspend /usr/sbin/pm-suspend
|
||||
action: hibernate /usr/sbin/pm-hibernate
|
||||
|
||||
# on FreeBSD use this instead of the above.
|
||||
#action suspend /usr/sbin/zzz
|
||||
|
||||
# root is allowed to do anything - but it needs to be here explicitly anyway
|
||||
user: root allow: *
|
||||
# members of operator, staff and admin groups should be able to do all
|
||||
group: operator allow: *
|
||||
group: staff allow: *
|
||||
group: admin allow: *
|
||||
group: sys allow: *
|
||||
group: wheel allow: *
|
||||
# common "user" groups for "console users" on desktops/laptops
|
||||
group: dialout allow: *
|
||||
group: disk allow: *
|
||||
group: adm allow: *
|
||||
group: cdrom allow: *
|
||||
group: floppy allow: *
|
||||
group: audio allow: *
|
||||
group: dip allow: *
|
||||
group: plugdev allow: *
|
||||
# put in a list of other users and groups here that are allowed or denied etc.
|
||||
# e.g.
|
||||
# user: myuser allow: *
|
||||
# user: another allow: suspend hibernate
|
||||
# deny everyone else by default
|
||||
user: * deny: *
|
13
x11-wm/enlightenment/files/quickstart.diff
Normal file
13
x11-wm/enlightenment/files/quickstart.diff
Normal file
@ -0,0 +1,13 @@
|
||||
Index: src/bin/e_main.c
|
||||
===================================================================
|
||||
--- src/bin/e_main.c (revision 61690)
|
||||
+++ src/bin/e_main.c (working copy)
|
||||
@@ -93,7 +93,7 @@
|
||||
static Eina_Bool _e_main_cb_startup_fake_end(void *data __UNUSED__);
|
||||
|
||||
/* local variables */
|
||||
-static Eina_Bool really_know = EINA_FALSE;
|
||||
+static Eina_Bool really_know = EINA_TRUE;
|
||||
static Eina_Bool locked = EINA_FALSE;
|
||||
static Eina_Bool inloop = EINA_FALSE;
|
||||
static jmp_buf x_fatal_buff;
|
Loading…
Reference in New Issue
Block a user