Remove enlightenment related ebuilds
This commit is contained in:
parent
3cd2b4d936
commit
b91891dd11
@ -1,2 +0,0 @@
|
||||
DIST efl-1.20.7.tar.xz 65509444 BLAKE2B f58f7daf850ef9983fe4b3a10a3ceb137be7f7ae32c71f476498f677de690bfcc7c16aea5032168a42aa6b5f97d1fb5ca51dafc69d80e2a9262f4d78220a8562 SHA512 c1bf18b74316cf9bd0bc16635c216ca0d8005b2ded1c014b22590388e37368343e5e5318f526dcb042cfce8ab2c7a82655e4718cbcac5dd1ed0d2522a7a2d7de
|
||||
EBUILD efl-1.20.7.ebuild 8710 BLAKE2B 5f8fff15a8300f5f42859898eda03f7634d07e95966e124a8915b74c8431494f22cf8374457999fd70ad9b43aeb2a8fac48a5b8b644104ba03a2751a87ed592b SHA512 3300ceda47a63dbc90c0d04b22c9110524bc432736cafe8adf88b2d01a81f9c389f3fe819b0787ef9b7ceac373f290634d4dfee7f48bea652126202cc8b92a67
|
@ -1,346 +0,0 @@
|
||||
# Copyright 1999-2018 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI="5"
|
||||
|
||||
MY_P=${P/_/-}
|
||||
|
||||
if [[ "${PV}" == "9999" ]] ; then
|
||||
EGIT_SUB_PROJECT="core"
|
||||
EGIT_URI_APPEND="${PN}"
|
||||
elif [[ *"${PV}" == *"_pre"* ]] ; then
|
||||
MY_P=${P%%_*}
|
||||
SRC_URI="https://download.enlightenment.org/pre-releases/${MY_P}.tar.xz"
|
||||
else
|
||||
SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.xz"
|
||||
KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
|
||||
fi
|
||||
|
||||
inherit enlightenment gnome2-utils pax-utils xdg-utils
|
||||
|
||||
DESCRIPTION="Enlightenment Foundation Libraries all-in-one package"
|
||||
|
||||
LICENSE="BSD-2 GPL-2 LGPL-2.1 ZLIB"
|
||||
IUSE="avahi +bmp dds connman debug drm +eet egl examples fbcon +fontconfig fribidi gif gles glib gnutls gstreamer harfbuzz hyphen +ico ibus ivi jpeg2k libressl libuv luajit neon opengl ssl pdf physics pixman postscript +ppm +psd pulseaudio raw scim sdl sound svg systemd tga tgv tiff tslib unwind v4l valgrind vlc vnc wayland webp X xcf xim xine xpresent xpm"
|
||||
|
||||
REQUIRED_USE="
|
||||
?? ( opengl gles )
|
||||
fbcon? ( !tslib )
|
||||
gles? (
|
||||
|| ( X wayland )
|
||||
!sdl
|
||||
egl
|
||||
)
|
||||
gnutls? ( ssl )
|
||||
ibus? ( glib )
|
||||
libressl? ( ssl )
|
||||
opengl? ( || ( X sdl wayland ) )
|
||||
pulseaudio? ( sound )
|
||||
sdl? ( opengl )
|
||||
vnc? ( X fbcon )
|
||||
wayland? ( egl !opengl gles )
|
||||
xim? ( X )
|
||||
"
|
||||
|
||||
RDEPEND="
|
||||
avahi? ( net-dns/avahi )
|
||||
connman? ( net-misc/connman )
|
||||
drm? (
|
||||
>=dev-libs/libinput-0.8
|
||||
media-libs/mesa[gbm]
|
||||
>=x11-libs/libdrm-2.4
|
||||
>=x11-libs/libxkbcommon-0.3.0
|
||||
)
|
||||
fontconfig? ( >=media-libs/fontconfig-2.5.0 )
|
||||
fribidi? ( >=dev-libs/fribidi-0.19.2 )
|
||||
gif? ( media-libs/giflib:= )
|
||||
glib? ( dev-libs/glib:2 )
|
||||
ssl? (
|
||||
gnutls? ( >=net-libs/gnutls-3.3.6 )
|
||||
!gnutls? (
|
||||
!libressl? ( dev-libs/openssl:0= )
|
||||
libressl? ( dev-libs/libressl:0= )
|
||||
)
|
||||
)
|
||||
gstreamer? (
|
||||
media-libs/gstreamer:1.0
|
||||
media-libs/gst-plugins-base:1.0
|
||||
)
|
||||
harfbuzz? ( >=media-libs/harfbuzz-0.9.0 )
|
||||
hyphen? ( dev-libs/hyphen )
|
||||
ibus? ( >=app-i18n/ibus-1.4 )
|
||||
jpeg2k? ( media-libs/openjpeg:0 )
|
||||
libuv? ( dev-libs/libuv )
|
||||
luajit? ( >=dev-lang/luajit-2.0.0 )
|
||||
!luajit? ( dev-lang/lua:* )
|
||||
pdf? ( >=app-text/poppler-0.45.0[cxx] )
|
||||
physics? ( >=sci-physics/bullet-2.80 )
|
||||
pixman? ( x11-libs/pixman )
|
||||
postscript? ( app-text/libspectre )
|
||||
media-libs/libpng:0=
|
||||
pulseaudio? ( media-sound/pulseaudio )
|
||||
raw? ( media-libs/libraw )
|
||||
scim? ( app-i18n/scim )
|
||||
sdl? (
|
||||
>=media-libs/libsdl2-2.0.0
|
||||
virtual/opengl
|
||||
)
|
||||
sound? ( media-libs/libsndfile )
|
||||
svg? (
|
||||
>=gnome-base/librsvg-2.36.0
|
||||
>=x11-libs/cairo-1.0.0
|
||||
)
|
||||
systemd? ( >=sys-apps/systemd-209 )
|
||||
tiff? ( media-libs/tiff:0= )
|
||||
tslib? ( x11-libs/tslib )
|
||||
unwind? ( sys-libs/libunwind )
|
||||
valgrind? ( dev-util/valgrind )
|
||||
vlc? ( media-video/vlc )
|
||||
vnc? ( net-libs/libvncserver )
|
||||
wayland? (
|
||||
>=dev-libs/wayland-1.11.0
|
||||
>=x11-libs/libxkbcommon-0.6.0
|
||||
media-libs/mesa[gles2,wayland]
|
||||
)
|
||||
webp? ( media-libs/libwebp )
|
||||
X? (
|
||||
>=media-libs/freetype-2.5.0.1
|
||||
x11-libs/libXcursor
|
||||
x11-libs/libX11
|
||||
x11-libs/libXcomposite
|
||||
x11-libs/libXdamage
|
||||
x11-libs/libXext
|
||||
x11-libs/libXfixes
|
||||
x11-libs/libXinerama
|
||||
x11-libs/libXrandr
|
||||
x11-libs/libXrender
|
||||
x11-libs/libXtst
|
||||
x11-libs/libXScrnSaver
|
||||
|
||||
opengl? (
|
||||
x11-libs/libX11
|
||||
x11-libs/libXrender
|
||||
virtual/opengl
|
||||
)
|
||||
|
||||
gles? (
|
||||
x11-libs/libX11
|
||||
x11-libs/libXrender
|
||||
virtual/opengl
|
||||
xpresent? ( x11-libs/libXpresent )
|
||||
)
|
||||
)
|
||||
xine? ( >=media-libs/xine-lib-1.1.1 )
|
||||
xpm? ( x11-libs/libXpm )
|
||||
|
||||
sys-apps/dbus
|
||||
>=sys-apps/util-linux-2.20.0
|
||||
sys-libs/zlib
|
||||
virtual/jpeg:0=
|
||||
|
||||
!dev-libs/ecore
|
||||
!dev-libs/edbus
|
||||
!dev-libs/eet
|
||||
!dev-libs/eeze
|
||||
!dev-libs/efreet
|
||||
!dev-libs/eina
|
||||
!dev-libs/eio
|
||||
!dev-libs/embryo
|
||||
!dev-libs/eobj
|
||||
!dev-libs/ephysics
|
||||
!media-libs/edje
|
||||
!media-libs/elementary
|
||||
!media-libs/emotion
|
||||
!media-libs/ethumb
|
||||
!media-libs/evas
|
||||
!media-plugins/emotion_generic_players
|
||||
!media-plugins/evas_generic_loaders
|
||||
"
|
||||
#external lz4 support currently broken because of unstable ABI/API
|
||||
# app-arch/lz4
|
||||
|
||||
#soft blockers added above for binpkg users
|
||||
#hard blocks are needed for building
|
||||
CORE_EFL_CONFLICTS="
|
||||
!!dev-libs/ecore
|
||||
!!dev-libs/edbus
|
||||
!!dev-libs/eet
|
||||
!!dev-libs/eeze
|
||||
!!dev-libs/efreet
|
||||
!!dev-libs/eina
|
||||
!!dev-libs/eio
|
||||
!!dev-libs/embryo
|
||||
!!dev-libs/eobj
|
||||
!!dev-libs/ephysics
|
||||
!!media-libs/edje
|
||||
!!media-libs/emotion
|
||||
!!media-libs/ethumb
|
||||
!!media-libs/evas
|
||||
"
|
||||
|
||||
DEPEND="
|
||||
${CORE_EFL_CONFLICTS}
|
||||
|
||||
${RDEPEND}
|
||||
doc? ( app-doc/doxygen )
|
||||
"
|
||||
|
||||
S=${WORKDIR}/${MY_P}
|
||||
|
||||
pkg_setup() {
|
||||
# Get clean environment, see bug 557408
|
||||
xdg_environment_reset
|
||||
chown portage:portage -R "${HOME}"
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
enlightenment_src_prepare
|
||||
|
||||
# Remove stupid sleep command.
|
||||
# Also back out gnu make hack that causes regen of Makefiles.
|
||||
# Delete var setting that causes the build to abort.
|
||||
sed -i \
|
||||
-e '/sleep 10/d' \
|
||||
-e '/^#### Work around bug in automake check macro$/,/^#### Info$/d' \
|
||||
-e '/BARF_OK=/s:=.*:=:' \
|
||||
configure || die
|
||||
|
||||
# Upstream doesn't offer a configure flag. #611108
|
||||
if ! use unwind ; then
|
||||
sed -i \
|
||||
-e 's:libunwind libunwind-generic:xxxxxxxxxxxxxxxx:' \
|
||||
configure || die
|
||||
fi
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
if use ssl && use gnutls ; then
|
||||
einfo "You enabled both USE=ssl and USE=gnutls, but only one can be used;"
|
||||
einfo "gnutls has been selected for you."
|
||||
fi
|
||||
if use opengl && use gles ; then
|
||||
einfo "You enabled both USE=opengl and USE=gles, but only one can be used;"
|
||||
einfo "opengl has been selected for you."
|
||||
fi
|
||||
|
||||
E_ECONF=(
|
||||
--with-profile=$(usex debug debug release)
|
||||
--with-net-control=$(usex connman connman none)
|
||||
--with-crypto=$(usex gnutls gnutls $(usex ssl openssl none))
|
||||
--with-x11=$(usex X xlib none)
|
||||
$(use_with X x)
|
||||
--with-opengl=$(usex opengl full $(usex gles es none))
|
||||
--with-glib=$(usex glib)
|
||||
--enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-abb
|
||||
|
||||
$(use_enable avahi)
|
||||
$(use_enable bmp image-loader-bmp)
|
||||
$(use_enable bmp image-loader-wbmp)
|
||||
$(use_enable dds image-loader-dds)
|
||||
$(use_enable drm)
|
||||
$(use_enable drm elput)
|
||||
$(use_enable doc)
|
||||
$(use_enable eet image-loader-eet)
|
||||
$(use_enable egl)
|
||||
$(use_enable examples always-build-examples)
|
||||
$(use_enable fbcon fb)
|
||||
$(use_enable fontconfig)
|
||||
$(use_enable fribidi)
|
||||
$(use_enable gif image-loader-gif)
|
||||
$(use_enable gstreamer gstreamer1)
|
||||
$(use_enable harfbuzz)
|
||||
$(use_enable hyphen)
|
||||
$(use_enable ico image-loader-ico)
|
||||
$(use_enable ibus)
|
||||
$(use_enable ivi wayland-ivi-shell)
|
||||
$(use_enable jpeg2k image-loader-jp2k)
|
||||
$(use_enable libuv)
|
||||
$(use_enable !luajit lua-old)
|
||||
$(use_enable neon)
|
||||
$(use_enable nls)
|
||||
$(use_enable pdf poppler)
|
||||
$(use_enable physics)
|
||||
$(use_enable pixman)
|
||||
$(use_enable pixman pixman-font)
|
||||
$(use_enable pixman pixman-rect)
|
||||
$(use_enable pixman pixman-line)
|
||||
$(use_enable pixman pixman-poly)
|
||||
$(use_enable pixman pixman-image)
|
||||
$(use_enable pixman pixman-image-scale-sample)
|
||||
--enable-image-loader-png
|
||||
$(use_enable postscript spectre)
|
||||
$(use_enable ppm image-loader-pmaps)
|
||||
$(use_enable psd image-loader-psd)
|
||||
$(use_enable pulseaudio)
|
||||
$(use_enable raw libraw)
|
||||
$(use_enable scim)
|
||||
$(use_enable sdl)
|
||||
$(use_enable sound audio)
|
||||
$(use_enable svg librsvg)
|
||||
$(use_enable systemd)
|
||||
$(use_enable tga image-loader-tga)
|
||||
$(use_enable tgv image-loader-tgv)
|
||||
$(use_enable tiff image-loader-tiff)
|
||||
$(use_enable tslib)
|
||||
$(use_enable v4l v4l2)
|
||||
$(use_enable valgrind)
|
||||
$(use_enable vlc libvlc)
|
||||
$(use_with vlc generic_vlc)
|
||||
$(use_enable vnc vnc-server)
|
||||
$(use_enable wayland)
|
||||
$(use_enable webp image-loader-webp)
|
||||
$(use_enable xcf)
|
||||
$(use_enable xim)
|
||||
$(use_enable xine)
|
||||
$(use_enable xpm image-loader-xpm)
|
||||
--enable-cserve
|
||||
--enable-image-loader-generic
|
||||
--enable-image-loader-jpeg
|
||||
|
||||
--disable-tizen
|
||||
--disable-gesture
|
||||
--disable-gstreamer
|
||||
--enable-xinput2
|
||||
--disable-xinput22
|
||||
--enable-libmount
|
||||
|
||||
# currently no JavaScript engine builds. Therefore:
|
||||
--with-js=none
|
||||
|
||||
# external lz4 support currently broken because of unstable ABI/API
|
||||
#--enable-liblz4
|
||||
)
|
||||
|
||||
use fbcon && use egl && E_ECONF+=('--enable-eglfs')
|
||||
use X && use xpresent && E_ECONF+=("--enable xpresent")
|
||||
|
||||
enlightenment_src_configure
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
if host-is-pax && use luajit ; then
|
||||
# We need to build the lua code first so we can pax-mark it. #547076
|
||||
local target='_e_built_sources_target_gogogo_'
|
||||
printf '%s: $(BUILT_SOURCES)\n' "${target}" >> src/Makefile || die
|
||||
emake -C src "${target}"
|
||||
emake -C src bin/elua/elua
|
||||
pax-mark m src/bin/elua/.libs/elua
|
||||
fi
|
||||
enlightenment_src_compile
|
||||
}
|
||||
|
||||
src_install() {
|
||||
MAKEOPTS+=" -j1"
|
||||
|
||||
enlightenment_src_install
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
gnome2_icon_cache_update
|
||||
xdg_mimeinfo_database_update
|
||||
}
|
||||
|
||||
pkg_postrm() {
|
||||
gnome2_icon_cache_update
|
||||
xdg_mimeinfo_database_update
|
||||
}
|
@ -1,4 +0,0 @@
|
||||
AUX gentoo-sysactions.conf 3056 BLAKE2B 155b0826c544a5a4829214b4b43d49e2dad455d041f0afc7077dc44780d12bd1a99a1bc94bb5a4a9ba21f59f679e1d4c82609791ee5a5e9828543b1e9154fae5 SHA512 688f02cbff0d50a847eb08ca7832699b836adca9b22e15a780943a8e5a8213aac04b335cfdf3cb96adbff238f681ae8954a720153e8e35b2afaba3225d53206a
|
||||
AUX quickstart.diff 474 BLAKE2B b5b46ccf535f08e1a7d8be64f2d548148efc24c5c9af31a1f0bfd67a94948eb535265d9b13d8fb65047ec9f22d924d16268bb2fa8ac03855e5513b0c60f771db SHA512 b8df654dd1246ea6391017fe9856e38d209b250625f8343aa4943a4eeed980447eb52c6a15fe170bcab90b76e5670ee9c7f98358bb87990877e312cc4cea8f6c
|
||||
DIST enlightenment-0.22.3.tar.xz 25648576 BLAKE2B 1abb1fab18c5932b65f1183875bbe0955ce1d608758af0855c550f5581c774bd19dd0b6c8dd8c724b668ff843e1ed4928531f30b60436d9182a07a65fa2af9e3 SHA512 01a9386ee009c76c46cee7176cdeb7f4e97977bdd5014caa51cceeff228ad72f97a362d1eff7e0240e3e2df8b24a6c9d1516c8ab05bd82d288abcfde0d171abd
|
||||
EBUILD enlightenment-0.22.3.ebuild 3267 BLAKE2B 152787f7cbea01dc1121fbea9c5d838e3e96a5b572988bac6b7883a0cbf8d103c98ed037d6fd8d222dbe938aa126c2ce3a4d77f70ba988c63fbb42385aa2eadc SHA512 b16ee1ea9881994b0caaab8e8ab2471b74623869b6f369a9aabed8d1d5a9da77554b597c6e35f8273441aeb0b6286e93d47d62d6c38b83169867496545246481
|
@ -1,125 +0,0 @@
|
||||
# Copyright 1999-2017 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI="5"
|
||||
|
||||
MY_P=${P/_/-}
|
||||
|
||||
if [[ ${PV} == *9999 ]] ; then
|
||||
EGIT_SUB_PROJECT="core"
|
||||
EGIT_URI_APPEND="${PN}"
|
||||
else
|
||||
SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${MY_P}.tar.xz"
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
|
||||
fi
|
||||
|
||||
inherit enlightenment
|
||||
|
||||
DESCRIPTION="Enlightenment DR17 window manager"
|
||||
|
||||
LICENSE="BSD-2"
|
||||
SLOT="0.17/${PV%%_*}"
|
||||
|
||||
__CONF_MODS=(
|
||||
applications bindings dialogs display
|
||||
interaction intl menus
|
||||
paths performance randr shelves theme
|
||||
window-manipulation window-remembers
|
||||
)
|
||||
__NORM_MODS=(
|
||||
appmenu backlight bluez4 battery
|
||||
clock conf connman cpufreq everything
|
||||
fileman fileman-opinfo gadman geolocation
|
||||
ibar ibox lokker
|
||||
mixer msgbus music-control notification
|
||||
pager packagekit pager-plain quickaccess
|
||||
shot start syscon sysinfo systray tasks teamwork temperature tiling time
|
||||
winlist wireless wizard wl-buffer wl-desktop-shell wl-drm wl-text-input
|
||||
wl-weekeyboard wl-wl wl-x11 xkbswitch xwayland
|
||||
)
|
||||
IUSE_E_MODULES=(
|
||||
${__CONF_MODS[@]/#/enlightenment_modules_conf-}
|
||||
${__NORM_MODS[@]/#/enlightenment_modules_}
|
||||
)
|
||||
|
||||
IUSE="pam spell static-libs systemd ukit wayland ${IUSE_E_MODULES[@]/#/+}"
|
||||
|
||||
RDEPEND="
|
||||
pam? ( sys-libs/pam )
|
||||
systemd? ( sys-apps/systemd )
|
||||
wayland? (
|
||||
dev-libs/efl[wayland]
|
||||
>=dev-libs/wayland-1.10.0
|
||||
>=x11-libs/pixman-0.31.1
|
||||
>=x11-libs/libxkbcommon-0.3.1
|
||||
)
|
||||
>=dev-libs/efl-1.18[X]
|
||||
x11-libs/xcb-util-keysyms"
|
||||
DEPEND="${RDEPEND}"
|
||||
|
||||
S=${WORKDIR}/${MY_P}
|
||||
|
||||
src_prepare() {
|
||||
epatch "${FILESDIR}"/quickstart.diff
|
||||
enlightenment_src_prepare
|
||||
}
|
||||
|
||||
# Sanity check to make sure module lists are kept up-to-date.
|
||||
check_modules() {
|
||||
local detected=$(
|
||||
awk -F'[\\[\\](, ]' '$1 == "AC_E_OPTIONAL_MODULE" { print $3 }' \
|
||||
configure.ac | sed 's:_:-:g' | LC_COLLATE=C sort
|
||||
)
|
||||
local sorted=$(
|
||||
printf '%s\n' ${IUSE_E_MODULES[@]/#enlightenment_modules_} | \
|
||||
LC_COLLATE=C sort
|
||||
)
|
||||
if [[ ${detected} != "${sorted}" ]] ; then
|
||||
local out new old
|
||||
eerror "The ebuild needs to be kept in sync."
|
||||
echo "${sorted}" > ebuild-iuse
|
||||
echo "${detected}" > configure-detected
|
||||
out=$(diff -U 0 ebuild-iuse configure-detected | sed -e '1,2d' -e '/^@@/d')
|
||||
new=$(echo "${out}" | sed -n '/^+/{s:^+::;p}')
|
||||
old=$(echo "${out}" | sed -n '/^-/{s:^-::;p}')
|
||||
eerror "Add these modules: $(echo ${new})"
|
||||
eerror "Drop these modules: $(echo ${old})"
|
||||
die "please update the ebuild"
|
||||
fi
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
check_modules
|
||||
|
||||
E_ECONF=(
|
||||
--disable-install-sysactions
|
||||
$(use_enable doc)
|
||||
$(use_enable nls)
|
||||
$(use_enable pam)
|
||||
$(use_enable systemd)
|
||||
--enable-device-udev
|
||||
$(use_enable ukit mount-udisks)
|
||||
$(use_enable wayland)
|
||||
)
|
||||
local u c
|
||||
for u in ${IUSE_E_MODULES[@]} ; do
|
||||
c=${u#enlightenment_modules_}
|
||||
# Disable modules by hand since we default to enabling them all.
|
||||
case ${c} in
|
||||
wl-*|xwayland)
|
||||
if ! use wayland ; then
|
||||
E_ECONF+=( --disable-${c} )
|
||||
continue
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
E_ECONF+=( $(use_enable ${u} ${c}) )
|
||||
done
|
||||
enlightenment_src_configure
|
||||
}
|
||||
|
||||
src_install() {
|
||||
enlightenment_src_install
|
||||
insinto /etc/enlightenment
|
||||
newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
|
||||
}
|
@ -1,76 +0,0 @@
|
||||
# ENLIGHTENMENT SYSTEM ACTIONS CONFIGURATION
|
||||
#
|
||||
# This is a system configuration for allowing or denying certain users or
|
||||
# groups to be able to do certain actions that involve system restricted
|
||||
# actions such as halt, reboot, suspend, hibernate etc.
|
||||
#
|
||||
# This file is read in order from top to bottom - the first rule to MATCH
|
||||
# will be used for a user or a group, and nothing after that is read.
|
||||
#
|
||||
# You must put all the ACTION definitons BEFORE user and group rule matches.
|
||||
# Any action definitons after a rule match has been found will be ignored.
|
||||
# This allows actions to be re-defined for different user groups, so matches
|
||||
# so the command for an action can change for matches to the rules later on.
|
||||
#
|
||||
# Any user or group NOT matched by an allow or a deny will be ALLOWED to
|
||||
# perform the action by default (system administrators should be aware of
|
||||
# this and implement whatever policies they see fit). Generally speaking
|
||||
# a user of a workstation, desktop or laptop is intended to have such abilities
|
||||
# to perform these actions, thus the default of allow. For multi-user systems
|
||||
# the system administrator is considerd capable enough to restrict what they
|
||||
# see they need to.
|
||||
#
|
||||
# A WARNING to admins: do NOT allow access for users to this system remotely
|
||||
# UNLESS you fully trust them or you have locked down permissions to halt/reboot
|
||||
# suspend etc. here first. You have been warned.
|
||||
#
|
||||
# FORMAT:
|
||||
#
|
||||
# action: halt /sbin/shutdown -h now
|
||||
# action: reboot /sbin/shutdown -r now
|
||||
# action: suspend /etc/acpi/sleep.sh force
|
||||
# action: hibernate /etc/acpi/hibernate.sh force
|
||||
#
|
||||
# user: username allow: halt reboot suspend hibernate
|
||||
# group: groupname deny: *
|
||||
# group: * deny: *
|
||||
# user: * allow: suspend
|
||||
# user: billy allow: halt reboot
|
||||
# group: staff deny: halt suspend hibernate
|
||||
#
|
||||
# etc.
|
||||
#
|
||||
# user and group name can use glob matches (* == all for example) like the
|
||||
# shell. as can action names allowed or denied.
|
||||
|
||||
action: halt /sbin/shutdown -h now
|
||||
action: reboot /sbin/shutdown -r now
|
||||
action: suspend /usr/sbin/pm-suspend
|
||||
action: hibernate /usr/sbin/pm-hibernate
|
||||
|
||||
# on FreeBSD use this instead of the above.
|
||||
#action suspend /usr/sbin/zzz
|
||||
|
||||
# root is allowed to do anything - but it needs to be here explicitly anyway
|
||||
user: root allow: *
|
||||
# members of operator, staff and admin groups should be able to do all
|
||||
group: operator allow: *
|
||||
group: staff allow: *
|
||||
group: admin allow: *
|
||||
group: sys allow: *
|
||||
group: wheel allow: *
|
||||
# common "user" groups for "console users" on desktops/laptops
|
||||
group: dialout allow: *
|
||||
group: disk allow: *
|
||||
group: adm allow: *
|
||||
group: cdrom allow: *
|
||||
group: floppy allow: *
|
||||
group: audio allow: *
|
||||
group: dip allow: *
|
||||
group: plugdev allow: *
|
||||
# put in a list of other users and groups here that are allowed or denied etc.
|
||||
# e.g.
|
||||
# user: myuser allow: *
|
||||
# user: another allow: suspend hibernate
|
||||
# deny everyone else by default
|
||||
user: * deny: *
|
@ -1,13 +0,0 @@
|
||||
Index: src/bin/e_main.c
|
||||
===================================================================
|
||||
--- src/bin/e_main.c (revision 61690)
|
||||
+++ src/bin/e_main.c (working copy)
|
||||
@@ -93,7 +93,7 @@
|
||||
static Eina_Bool _e_main_cb_startup_fake_end(void *data __UNUSED__);
|
||||
|
||||
/* local variables */
|
||||
-static Eina_Bool really_know = EINA_FALSE;
|
||||
+static Eina_Bool really_know = EINA_TRUE;
|
||||
static Eina_Bool locked = EINA_FALSE;
|
||||
static Eina_Bool inloop = EINA_FALSE;
|
||||
static jmp_buf x_fatal_buff;
|
Loading…
Reference in New Issue
Block a user