dev-python/qarnot: new package

Package-Manager: portage-2.3.0
This commit is contained in:
nemunaire 2016-10-14 20:12:31 +02:00
parent 36e299d148
commit 847738e234
5 changed files with 82 additions and 0 deletions

View File

@ -3,6 +3,7 @@ Nemunaire Gentoo Overlay
This overlay includes ebuilds for the following packages:
* `dev-python/qarnot`: Qarnot computing SDK (https://computing.qarnot.com)
* `net-im/netsoul-purple`: Netsoul plugin for libpurple (https://github.com/sekh/netsoul-purple)
Usage with Layman

View File

@ -0,0 +1,4 @@
AUX 0001-Test-with-requests-2.8.1.patch 464 SHA256 beb5236f6d56b74053ecdd44b5ed593a3e5d4e0a1d99d7b6b0232f6690944dc8 SHA512 acee36a7141e818e2b8140c8638370e0232304421824eb4d8dae33012f795e5aa338fbada3e158cf8a67819ca32e28a3a6bb0d24b620080dbb68034e8ff8f183 WHIRLPOOL 230ce756cd836281807e1c578a87e1e7741e3f8120585f136b39c286a26ea160e998fa0a9a737a607db49f3c5c46bcaeb1b82ec501df285a53e0426787f48285
DIST qarnot-1.0.1.tar.gz 55222 SHA256 a4d385024ef59397b6ef39e110abac38ee3860996d615d614794bc8b5214efd3 SHA512 8e03d69d45fc6782e37e540679e920de44cceea8f50c289628f70f741515bc11730a93cb8e969ccdc6c7cf278ae3d772a321887d9dc45fb22aa6f61f5687c203 WHIRLPOOL c6c47dc509f3ef401861a2503b351eedaf5014b62eadb09ebe6c82de7627af24009071212dff043efd8f89535c274bc9cb7e8e0831c9b4d6aa918d443373c303
EBUILD qarnot-1.0.1.ebuild 1042 SHA256 581d765e9292b2c7e40650ca5a4cbdcbf1472641ac26f56b4480ffe411bdd293 SHA512 11785242c72069db763f335864840672ea3e8f6dc41eea17795e0fccbb1fa647cd66d98bc61b7e4affa66478d6e043605c2a87e6c4116155447f349e61f46399 WHIRLPOOL a9d9eacb5906895d7a987437c6050f609b01226d0984a4d0cdc3ad93da756ee8d5a30892ecebe39586d74dbe369b59c5f7490d80544a36d1384ce694cb0fb817
MISC metadata.xml 330 SHA256 a1cd192561a0ee11aad21997672bbe52112310a952b894517c34fae442a3a6b8 SHA512 ce755563c3da008837b3f6e0f9d6d3aa7d2fa3d7e581e53e5578ab66fed5f249a591fb4e6c6875ed50dbe06c100e04154364bcd2b8cc83f7521c5d302f80fd3b WHIRLPOOL 19553bd675c293dd84082a79ab49f9314d332e55d13e6d61e522ed59778cf8780efb0a642eb9cabcd24555ab42b01c49403d3c6c37383836b4b62fc2ad7045ea

View File

@ -0,0 +1,19 @@
From cefc242dbfa40b781a1ddb32ff18565c7a0723e6 Mon Sep 17 00:00:00 2001
From: Pierre-Olivier Mercier <nemunaire@nemunai.re>
Date: Fri, 14 Oct 2016 18:07:32 +0200
Subject: [PATCH] Test with requests 2.8.1
---
requirements.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/requirements.txt b/requirements.txt
index 4661030..99da7b1 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1 +1 @@
-requests==2.11.1
+requests==2.8.1
--
2.7.3

View File

@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>nemunaire@nemunai.re</email>
<name>Pierre-Olivier Mercier</name>
</maintainer>
<longdescription lang="en">
Qarnot computing SDK
</longdescription>
</pkgmetadata>

View File

@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
DESCRIPTION="Qarnot computing SDK"
HOMEPAGE="https://computing.qarnot.com/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
IUSE="doc test"
RDEPEND="
>=dev-python/requests-2.8.1[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
doc? ( dev-python/sphinx )
test? ( dev-python/pytest )
"
PATCHES=(
"${FILESDIR}/0001-Test-with-requests-2.8.1.patch"
)
python_prepare_all() {
distutils-r1_python_prepare_all
use doc && emake -C doc html
}
python_test() {
python "${S}/setup.py" test || die "tests fail under ${EPYTHON}"
}
python_install_all() {
use doc && HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static,_modules,api} )
distutils-r1_python_install_all
}